Upgrading On-Premise Poller to the latest version

Upgrading On-Premise Poller to the latest version

  • Go to Admin > On-Premise Poller in the Site24x7 web client
  • Click on the name of the On-Premise Poller
  • In the dashboard that opens up, click upgrade to the latest version

  • Confirm it in the pop-up
  • The latest version of the On-Premise Poller will be automatically downloaded and installed. 
The download might require a few minutes to complete based on your internet speed. Once downloaded, the latest version will be installed automatically, and the monitoring will be restarted.
If the upgrade fails, you can also manually upgrade the On-Premise Poller.

    • Related Articles

    • Moving a device from one On-Premise Poller to another

      You can always change the On-Premise Poller that monitors your device when your needs demand. This feature also helps to balance the load on an existing On-Premise Poller by moving some monitors to another On-Premise Poller. Log in to your Site24x7 ...
    • Prerequisites for an On-Premise Poller to be assigned as a standby for another On-Premise Poller

      The On-Premise Poller that is being associated as standby On-Premise Poller must not be in a down or suspended state. The On-Premise Poller version should be 4.3.0 or above. The On-Premise Poller should not have any monitor associated with it. The ...
    • How to manually upgrade an On-Premise Poller

      You can upgrade an On-Premise Poller directly from the Site24x7 web console by navigating to Admin > On-Premise Poller, clicking the hamburger icon beside an On-Premise Poller, and clicking Upgrade. If this upgrade fails, try using the steps below: ...
    • Manage log files filling up on an On-Premise Poller

      The limit for a single log file is 10 MB. Beyond this, we will rotate the logs up to 10 files, giving a maximum of 100 MB for a single module.  Likewise, we have 7-8 modules. This depends on the customer's usage of Poller and the number of monitors ...
    • Prerequisites for installing On-Premise Poller

      Site24x7 On-Premise Poller can be installed on Windows and Linux systems in both 32-bit and 64-bit versions. On-Premise Poller can be installed in virtual machines as well. The following are the general prerequisites for installation: RAM 8 GB ...