Troubleshooting instructions for Windows server monitor being reported down after Windows BSOD (CrowdStrike)

Troubleshooting instructions for Windows server monitor being reported down after Windows BSOD (CrowdStrike)

Issue

The server monitor is down on the devices affected by the recent Windows-CrowdStrike BSOD issue.

Cause

After the BSOD, the affected devices are unable to start the Site24x7 Windows Agent service. When the customer tries to start the agent, it fails with error code 1608.


Upon analyzing the root cause of this issue, we found that all the groups and users that were previously associated with the agent install directory have been cleared after the BSOD.

Resolution

Add SYSTEM and Administrators to the groups and user names for the agent install directory and grant full control permission.
To perform this fix easily, we have created a script. When this script is executed as an administrator, all the required users and groups with permissions will be added to the directory.





    • Related Articles

    • Troubleshooting tips for log collection errors

      The following is a list of possible log collection errors and the solutions to fix them: Error message Reason Solution Upload Limit Reached You might have reached the maximum upload limit configured for this log type in the current billing cycle. ...
    • How do we verify the Site24x7 Windows Server Monitoring Agent script?

      All the scripts and executables in the Site24x7 Windows Server Monitoring Agent are digitally signed. To verify the digital signature, we compare the certificate name and the serial number of the digital signature associated with the script with our ...
    • How do you enable or disable Management Actions in your Windows server?

      Management Actions can be used to start or stop VM configurations in a Hyper-V server, services in a Windows server, or sites and application pools in an IIS server. These actions can't be performed if Management Actions is disabled in the server ...
    • Possible outage scenarios and their troubleshooting steps for a server monitor

      The following table list the possible outage scenarios and steps to resolve them: Possible Scenarios Troubleshooting Steps The server was never up since installing the agent. Try using a proxy to connect to the internet. Learn how to set a proxy for ...
    • Install and configure an Oracle plugin in Windows

      Prerequisites Ensure that the Site24x7 Windows server monitoring agent is installed in the system where the Oracle instance is running. Ensure python3 is installed in the system and add it to the Windows path. Refer to the link below for adding ...